Ducati Hyperstrada Forum

Ducati Hyperstrada Forum (http://hyperstrada.com/ducati-hyperstrada-forums.php)
-   Mechanical and Technical (http://hyperstrada.com/mechanical-technical/)
-   -   Limp home recall (http://hyperstrada.com/mechanical-technical/2384-limp-home-recall.html)

Paab June 4th, 2015 01:54 PM

Limp home recall
 
I brought my hyper in for the 1st service and told them I had a limp home incident. They said there is a recall on a part in the throttle assembly for this issue. They had to order it for me, so it's not done yet. They did say just turning it off and back on clears the limp mode... for a while.

He said you can even do it on the fly. Just squeeze the clutch key off for a couple seconds key on and go. But that is off the record! :p

gatdammit June 4th, 2015 02:38 PM

Oh, I'm a pro at the running restart!

So, I'm guessing you have a 2014? Did they say if it covers 2013's, too? There was no fix for this last time I complained to my dealer. Some got there TPS swapped but there was no actual updated part.

zibbit u2 June 4th, 2015 03:20 PM

Put it this way.. If you've installed heated grips chances are the recal is considered taken care of. There's a notable difference in throttle feel of a factory '13 vs new heated grip kit.

Paab June 4th, 2015 05:41 PM

Hmmm, well, I did install the heated grips and so have a brand new throttle assembly. I just got it back though, so I haven't ridden it yet.

I have a 2013 and the part was covered. He said it heavily effected certain bikes, and that mine was in the range that should have been bad, but it only happened once in 1000 miles.

Paab June 5th, 2015 08:14 AM

Question for zibbit. Did you have limp home issues? Did the heated throttle solve them?

zibbit u2 June 5th, 2015 10:04 AM

I've had zero issues so far *knock on wood*

Paab June 5th, 2015 10:13 AM

OK, well, perhaps I'll wait and see before installing the updated part.

Paab June 11th, 2015 06:53 PM

Heated grip throttle is indeed smoother than stock. Seems to have eliminated the unpredictable nature of the stock one.

ferdi June 12th, 2015 09:42 AM

i have heated grips and i think i had the "limp home mode problem" today.
after starting and driving away suddenly the bike did not rev free, feeled without power and did not rev above 5000, and this very slowly. also in neutral gear id did not rev higher than 5000 rpm.
switched off ignition, switched on again and started and problem was gone.

zibbit u2 June 12th, 2015 12:33 PM

Ferdi yours kinda sounds like a clutch or neutral switch issue. The bike if there's an error with one of them limits the rpm to around 4000-5000 rpm to protect against over rev.


All times are GMT -8. The time now is 07:44 PM.


Ducati Hyperstrada Motorcycle Forum
Copyright © 2012-2014 HYPERSTRADA.COM • All rights reserved.