Ducati Hyperstrada Forums Ducati Hyperstrada Motorcycle

Go Back   Ducati Hyperstrada Forum > Ducati Hyperstrada Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions


Reply
 
LinkBack Thread Tools Display Modes
Old September 7th, 2015, 03:17 AM   #1
Senior Member
 
Joined: Jan 2015
From: Austria
Posts: 291

I Ride: 2016 Hyperstrada 939, red
error code P0608 and P0609

has anyone already had these codes ?

symptom - bike suddenly throws yellow MIL and motor stops.
ignition off/on lets bike start again.

happened last weekend 3 times to me, on the track.
first time maybe i did a mistake between 4th and 5th gear and found the neutral between and bike may have overreved. I am not sure, but maybe.
other 2 times it happened one time on a straight and one time in the middle of a middlefast turn.
can the reason be that bike throws these codes and MIL after some overreving into revlimiter ? This happened several times to me, but not exactly when the yellow lamp came. 2nd and 3rd occasion definitly was not an overreving at that time. maybe sometimes before.


P0608 - Control Module VSS Output "A" Malfunction
P0609 - Control Module VSS Output "B" Malfunction

What do these codes mean ?

I read and deleted codes with my Rexxer Evo User.


Never had this in the 5000 km before since i own my HS, first time on track - was Slovakiaring, a quite fast track
ferdi is offline   Reply With Quote
 
Old September 8th, 2015, 12:35 AM   #2
Senior Member
 
Joined: Jan 2015
From: Austria
Posts: 291

I Ride: 2016 Hyperstrada 939, red
Has really nobody had this problem before me ?

Maybe someone had CEL and stalling motor and does not know which errorcode was written ?
Because i suppose most people cannot read errorcodes by themselve.
ferdi is offline   Reply With Quote
Old September 8th, 2015, 05:16 AM   #3
Senior Member
 
Joined: May 2014
From: Charlottesville, VA
Posts: 251

I Ride: 13 hyperstrada, montesa trials, selling Duc 900 SS CR
No, I have not had the bike stop running.
What is yellow MIL? What is CEL?
BlueSwede is offline   Reply With Quote
Old September 8th, 2015, 06:45 AM   #4
Senior Member
 
Joined: Jan 2015
From: Austria
Posts: 291

I Ride: 2016 Hyperstrada 939, red
Quote:
Originally Posted by BlueSwede View Post
No, I have not had the bike stop running.
What is yellow MIL? What is CEL?
Malfunction Indicator Light (MIL) ,
check engine light (CEL) - https://en.m.wikipedia.org/?title=Ch...ht&redirect=no


its the yellow lamp with the engine sign, which tells you that you have a serious motor problem.
how is it named right in US ?

Last edited by ferdi; September 8th, 2015 at 06:49 AM.
ferdi is offline   Reply With Quote
Old September 8th, 2015, 09:33 AM   #5
Senior Member
 
Joined: May 2014
From: Charlottesville, VA
Posts: 251

I Ride: 13 hyperstrada, montesa trials, selling Duc 900 SS CR
ok, yellow check engine light, got it. Thanks for clarifying.

I am actually due for the throttle recall. I will very occasionally get a temporary malfunction, I presume from the flaws in that assembly. I have not had any event where it actually stopped the engine, and only 2 or 3 limp modes, which cleared with a restart. As it happens, I had the yellow engine light come on very briefly this morning, but it cleared itself in 1/8 of a mile and there was no limp mode, nor any other abnormal behavior.

I am not familiar with any error codes. Do the codes you see actually come up on your bike's screen, or are you reading them when you connect through the rexxer software?
BlueSwede is offline   Reply With Quote
Old September 8th, 2015, 12:14 PM   #6
Senior Member
 
Joined: Jan 2015
From: Austria
Posts: 291

I Ride: 2016 Hyperstrada 939, red
what happened was engine light and motor stopped.
ignition off/on and i could restart and drive normally.
this happened 3 x on day 2 of the trackday-weekend.
but it was dangerous, 1 time a fast driver was right behind me and i got slow very suddenly where i should have accelerated.

the errocodes only were visible with rexxer user box. there is a diagnostic function where you can look for errocodes and delete them also.

the errorcodes point to both speed sensors, which is a little strange.

also my dealer has no idea and does not remember they had already these codes on another bike.

my hope was that someone in forum had this already, even i did not find any entry of P0608 / P0609 here or in Ducati.ms forum.

limp mode i had only 1 time, some time ago, but as you, without stalling and it went away with igniton off/on.

Last edited by ferdi; September 8th, 2015 at 12:17 PM.
ferdi is offline   Reply With Quote
Old September 8th, 2015, 01:11 PM   #7
Senior Member
 
Joined: May 2014
From: Charlottesville, VA
Posts: 251

I Ride: 13 hyperstrada, montesa trials, selling Duc 900 SS CR
It sounds rather unpleasant to have the motor quit just at that moment...!
Glad to hear you are ok, and I really hope you can sort out the errors. Wish I could be of help, but I have no expertise in this area. I guess the dealer and their connection to the factory tech support is your best option.
BlueSwede is offline   Reply With Quote
Old September 13th, 2015, 08:32 PM   #8
Senior Member
 
gatdammit's Avatar
 
Joined: Mar 2013
From: North Florida, USA
Posts: 1,875

I Ride: 2013 White Strada
I've over revved a few times on the roll with no issues. It's easy to over rev when the bike slips neutral in the upper gears.

When my bike was very new, mine would stall occasionally when shifting between upper gears, but no CEL. Any early recall fixed this.
gatdammit is offline   Reply With Quote
Old September 14th, 2015, 12:41 AM   #9
Senior Member
 
Joined: Jan 2015
From: Austria
Posts: 291

I Ride: 2016 Hyperstrada 939, red
Quote:
Originally Posted by gatdammit View Post
I've over revved a few times on the roll with no issues. It's easy to over rev when the bike slips neutral in the upper gears.

When my bike was very new, mine would stall occasionally when shifting between upper gears, but no CEL. Any early recall fixed this.
thank you.

In a week, next monday, i will be again at a trackday on pannoniaring in hungary, and i will mount my camera with dashboard in sight, to look at which occasions it occurs, if it will happen again.
My dealer asked Ducati Italia about the codes but did not get any answer until yet.
ferdi is offline   Reply With Quote
Old September 22nd, 2015, 10:32 AM   #10
Senior Member
 
Joined: Jan 2015
From: Austria
Posts: 291

I Ride: 2016 Hyperstrada 939, red
just to inform you guys if someone encounters this or a similar problem.
i found the reason for the problem - it seems to be my healtech gear indicator.

this monday on trackday it occured 3 times during the first session. so i did a try and disconnected the healtech.
voila - it did not happen again all the day. so i am quite sure that this is the problemcause.
but, i do not know if its simply the power, which i used from the back fuse no 7 (ecu) because at all other fuses the display still showed last values after ignition off.
or, more propably, it's the main connection to canbus diagnostic plug.

anyway - unpluging it from diagnostic plug solved the big problem for the day.

i will keep an eye on it at roaduse, where the problem never occured until yet. if it occurs there also, i will disconnect it for ever.
ferdi is offline   Reply With Quote
Reply

  Ducati Hyperstrada Forum > Ducati Hyperstrada Forum > Mechanical and Technical

Tags
code, error, p0608, p0609



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Error" and all dash lights flashing, Fan Turns on, No Start…. michdave Ducati Hyperstrada 272 September 14th, 2017 05:50 PM
"Flashing Dashes" Odometer Error AJsarge Ducati Hyperstrada 17 May 5th, 2016 06:09 AM
error code P0608 and P0609 ferdi Mechanical and Technical 0 September 7th, 2015 03:11 AM
Color code for Hyperstrada - Hypermotard SP gkmapv Ducati Hyperstrada 39 May 16th, 2015 03:26 PM


Ducati Hyperstrada Facebook Ducati Hyperstrada Twitter Ducati Hyperstrada RSS Feed



Ducati Hyperstrada Motorcycle Forum
Copyright © 2012-2014 HYPERSTRADA.COM • All rights reserved.