Ducati Hyperstrada Forums Ducati Hyperstrada Motorcycle

Go Back   Ducati Hyperstrada Forum > Ducati Hyperstrada Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions


Reply
 
LinkBack Thread Tools Display Modes
Old September 5th, 2016, 01:05 PM   #1
Junior Member
 
Joined: Aug 2016
From: Berwick upon Tweed
Posts: 14

Flickering oil light on bumpy roads

Good evening!

I've had my HS for a month and 1300 miles now and had no problems aside from the oil light very occasionally flickering when accelerating hard on really bumpy roads. It's difficult to pinpoint an exact scenario but it seems like it happens when the bike is topping its suspension out or maybe getting a little air and also when accelerating out of bumpy left handers. In the last say 500 miles it's happened around 3 times for 1-2 seconds.

The bike has had its first service and the oil level is spot on + I can't see any leaks, so I'm thinking its a sensor thing as opposed to a real oil pressure issue?

Has anyone experienced anything similar and/or should I be concerned?

Cheers,

Phil
phil808 is offline   Reply With Quote
 
Old September 5th, 2016, 02:36 PM   #2
Senior Member
 
Joined: Jul 2014
From: California
Posts: 1,201

Probably just a loose connection then - if you have oil I doubt it's actually losing oil pressure for a second.
kuksul08 is offline   Reply With Quote
Old September 6th, 2016, 04:41 AM   #3
Senior Member
 
Joined: Jan 2015
From: Austria
Posts: 328

I Ride: 2016 Hyperstrada 939 red, 2006 MotoMorini Corsaro 1200 black/silver, 2005 Aprilia RSV1000R Factory
Are you sure it's the oil light and not the red light for traction control ?
ferdi is offline   Reply With Quote
Old September 6th, 2016, 06:44 AM   #4
Senior Member
 
monocog007's Avatar
 
Joined: Oct 2015
From: Minnesota
Posts: 545

I Ride: 13' Hyperstrada, 00' M900Sie
Quote:
Originally Posted by ferdi View Post
Are you sure it's the oil light and not the red light for traction control ?
This is the more likely case. I didn't even think this might be the issue until you mentioned it.
monocog007 is offline   Reply With Quote
Old September 6th, 2016, 11:32 AM   #5
Junior Member
 
Joined: Aug 2016
From: Berwick upon Tweed
Posts: 14

Yeah, it's definitely the oil light - it's red, in the middle of the cluster (on the 939) and had the little oil-can icon on it. As suggested it's gotta be a connection problem so I'll hunt down the cables and give everything a push.

Thanks for advice - I'm off to Europe next week and just wanted to check that it wasn't a genuine oil-pressure issue that other folk had seen. Looks like I'm good to go!

Cheers,

Phil.
phil808 is offline   Reply With Quote
Old October 12th, 2016, 09:52 AM   #6
Junior Member
 
Joined: Jul 2016
From: Chicago, IL
Posts: 14

If you hadn't had the post break-in service I would be concerned that metal shavings were blocking the oil pickup and giving you low pressure. I had to rebuild a motor on my golf due to a similar problem. It might be worth it to change the oil and filter again if you are paranoid about it.


Sent from my iPad using Tapatalk
shakeszilla is offline   Reply With Quote
Old October 12th, 2016, 11:53 AM   #7
Senior Member
 
Joined: Feb 2016
From: CT
Posts: 123

The red light in the center of my cluster is TC and rev limiter, isn't it? I'm now questioning things lol
astrocortex is offline   Reply With Quote
Old October 12th, 2016, 11:58 AM   #8
Senior Member
 
monocog007's Avatar
 
Joined: Oct 2015
From: Minnesota
Posts: 545

I Ride: 13' Hyperstrada, 00' M900Sie
Both on the 939.

monocog007 is offline   Reply With Quote
Old October 13th, 2016, 11:22 AM   #9
Junior Member
 
Joined: Aug 2016
From: Berwick upon Tweed
Posts: 14

Yep - that's the one...Anyway I fiddled with every connector I could find and it seems to have stopped - at least it didn't come on during a 2800 mile around Europe - on which, the bike didn't use any oil at all. Now got 4500 miles on the clock so I'm feeling pretty safe.

Cheers,

Phil.
phil808 is offline   Reply With Quote
Reply

  Ducati Hyperstrada Forum > Ducati Hyperstrada Forum > Mechanical and Technical

Tags
bumpy, flickering, light, oil, roads



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best roads for the Hyperstrada RSL Ducati Hyperstrada 37 April 21st, 2017 10:28 AM
Rear turn light to led light Yama Hu Mechanical and Technical 2 March 27th, 2016 07:35 AM
Termignoni dB ok for German roads? treeper Ducati Hyperstrada 3 March 18th, 2015 08:55 AM
Flickering Red Light amhobby Mechanical and Technical 2 April 7th, 2014 05:14 PM
Tricky roads NewRider Motorcycle Talk 15 January 17th, 2014 05:25 AM


Ducati Hyperstrada Facebook Ducati Hyperstrada Twitter Ducati Hyperstrada RSS Feed



Ducati Hyperstrada Motorcycle Forum
Copyright © 2012-2014 HYPERSTRADA.COM • All rights reserved.