Ducati Hyperstrada Forums Ducati Hyperstrada Motorcycle

Go Back   Ducati Hyperstrada Forum > Ducati Hyperstrada Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions


Reply
 
LinkBack Thread Tools Display Modes
Old October 12th, 2019, 10:39 PM   #1
Senior Member
 
Joined: Jul 2014
From: California
Posts: 1,253

Rapidbike and engine light

Just thought I'd share here some info I got today. When I sold my Hyper, it got a check engine light shortly afterward with an "errors" message. The bike still ran fine with no issues.

The new owner did everything he could including a new battery, replaced both O2 sensors, took it to the dealer, disconnecting power, etc. and could not resolve it for about a year. Finally he plugged into the Rapidbike and reverted to factory settings and did a firmware update. The light went away.

I am guessing the O2 signal from the RB to the factory harness was not functioning right and doing a reset fixed it. Hope this helps someone!
kuksul08 is offline   Reply With Quote
 
Old October 15th, 2019, 12:22 AM   #2
Senior Member
 
gatdammit's Avatar
 
Joined: Mar 2013
From: Naples, IT
Posts: 2,306

I Ride: 2013 White Strada
Thanks, Kuk.

I just got mine back from a local Italian mechanic. While he said the RB is the best consumer tuner out there, he said it certainly can have it's share of issues. He got my bike running (not blowing #4 fuse) but said the CEL/ ERRORS was "most likely" related to an engine speed mis-compare between ECU and RB in the horizontal cylinder. Possibly the lambda.

Bike ran strong for 3 weeks. This past Friday, I was pulling into my neighborhood and felt the engine chug a little when back on the gas. Almost felt like limp mode but I didn't get the chance to troubleshoot further as it wouldn't start after parking it. CEL and ERRORS on with AC power; extinguish when I thumb starter; nothing turns; lights return when starter released. No blown fuses.

I have new O2's in the mail, but disconnecting them didn't affect anything. I left the batter disconnected for 3 days, disconnected/ reconnected every lead...nada.

I will not buy a new ECU. That's like 1/5 of the bikes value. I love her but, the reliability is killing me right now. Driving a car to work sucks for me and I'm missing the best riding weather in Europe. I also have to rent a van (nobody owns trucks here) and drive 1.5 hrs to drop the bike off.
gatdammit is offline   Reply With Quote
Old October 15th, 2019, 07:25 PM   #3
Senior Member
 
Joined: Jul 2013
From: Tujunga
Posts: 111

I Ride: Hyperstrada White
Damn this hurts to see. Me and a friend are in the same boat with each of us having a bad ecu. I really hate that Ducati won't stop up and replace them for us.
krolinked is offline   Reply With Quote
Old October 16th, 2019, 12:35 AM   #4
Senior Member
 
gatdammit's Avatar
 
Joined: Mar 2013
From: Naples, IT
Posts: 2,306

I Ride: 2013 White Strada
Almost any other component on the bike I can swallow as consumable. But 20K miles on a device that rarely dies in an automobile is insane. Not to mention it's probably the most expensive single piece component...used one's run $600.

I just can't believe they're still validating the stereotype about Italian exotics and electronics. VW had this problem in the late 90's when a power window regulator had about a 6 month life span. It hurt sales and branding so they fixed it. This is the kind of shit that makes a fan like me run out and by a Honda.
gatdammit is offline   Reply With Quote
Old October 16th, 2019, 02:55 PM   #5
Senior Member
 
Joined: Jul 2014
From: California
Posts: 1,253

Yeah agreed. I have to admit part of the reason I sold my hyper was the paranoia of an electrical failure, even though it never had one (other than the starter motor).

I would try bypassing the rapidbike completely - plug your stock O2's into the factory harness, and see what happens. They also sell a kit where you can remove the RB unit and plug in a jumper which basically removes the unit and acts like a stock bike, for diagnostic purposes. Can't say i would buy another RB unit after using it and hearing of issues. I'd probably go for a flash tune.
kuksul08 is offline   Reply With Quote
Old October 16th, 2019, 11:27 PM   #6
Senior Member
 
gatdammit's Avatar
 
Joined: Mar 2013
From: Naples, IT
Posts: 2,306

I Ride: 2013 White Strada
I have the bypass plug...somewhere. When I get the new O2's, I'm gonna go scorched earth on the RB. If it's the ECU, hopefully my local mechanic can find a good used one.
gatdammit is offline   Reply With Quote
Reply

  Ducati Hyperstrada Forum > Ducati Hyperstrada Forum > Mechanical and Technical

Tags
engine, light, rapidbike



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting EOBD (ENGINE/DIAGNOSTIC) LIGHT ON - ERROR: ENGINE jgirado Ducati Hyperstrada 6 January 29th, 2019 12:41 PM
Red oil light - Engine Break-in Exxes Ducati Hyperstrada 2 September 25th, 2017 10:46 AM
Engine light warning NeilG Mechanical and Technical 1 February 29th, 2016 01:48 PM
Check engine light wheelieboy1 Mechanical and Technical 3 March 24th, 2015 05:06 PM


Ducati Hyperstrada Facebook Ducati Hyperstrada Twitter Ducati Hyperstrada RSS Feed



Ducati Hyperstrada Motorcycle Forum
Copyright © 2012-2014 HYPERSTRADA.COM • All rights reserved.