Dead high beam...

Jun 2017
113
0
Merced CA
So today while riding I look down and notice the blue high beam indicator on the dash was blinking instead of staying on with the high beam on. I was stopped behind a van so I hit the high beam switch(to turn the high beam off) and noticed the reflection of the low beam in the van in front of me. Turn the high beam back on and get no light at all and the blue indicator light starts flashing again. I ride with the high beam on a lot so I figure that it's just burned out. No big deal, I'll get a new bulb and install it.

I'm not looking to put some new fangled LED bulb or some HID mess in there. Just want to put in another stock bulb. I very rarely ride at night so I don't need anything more than that.

So I'm hoping someone here can tell me which bulb I need to get to replace the one I have? Again, just looking for an OEM replacement. I guess I could look in the owners manual but that's packed away and my laptop is right here so...LOL. TIA!

EDIT: It's for a 2016 Hyperstrada 939
 
Oct 2016
368
1
San Francisco
I believe I got the silverstar ultra or whatever the fanciest bulb autozone had after mine died. Nothing like swapping a bulb after dark in the parking lot on the first day or a road trip. It's brighter than stock and seems to annoy drivers a bit as cars tend to move out of my way more frequently than I recall prior.
 
Jun 2017
113
0
Merced CA
You didn't have to modify anything to get that to fit? With the bulb installed the rear cover/door thing still fit on the headlight housing? I would be worried about heat build up in the housing but I don't know if that would be a real issue or not. I just assume those heat sinks would get hotter than the normal H4 bulb.