Random Stalling

May 2018
13
0
Brazil
Am hoping I can get some answers from fellow owners.

2013 821. I got it in March with ~700 miles.
Mechanically bone stock except for a GPR exhaust can I recently installed.

I noticed early on that once in a while the bike would stall as I decelerate to come to a stop (after I press in the clutch to downshift).
Took to dealer in May and they believed the AIS valves had carbon buildup, as they were giving wonky readings on the computer. they cleaned them up and all was fine for a month or so.

Now with 2,000 or so miles on the bike, am noticing the issue has returned and on every other ride, I will get the random stall. starts right up after stalling (fun to do as you are rolling and realize the engine died)

As I mentioned, no mechanical mods to the bike other than the GPR can (condition existed prior to installing it).

happens whether it is 40 degrees or 90 degrees out.
Thoughts?
Did you ever get this fixed? What solved it?
 
Mar 2018
69
0
Charleston, SC
Well, for the most part. Dealer found high carbon build up on the reed valves. they cleaned them up and I only had the bike stall 2 or 3 times over the winter.

I'm actually taking it in tomorrow for a belt change and just having them take off the evap canister. I'm thinking that also contributed to the issue.
 
Last edited:
Mar 2013
2,334
4
Naples, IT
Oh, yes. Shit can the EVAP canister. Mine wasn't on long enough to even know if would cause stalling but my dealer said it is troublesome.
 
May 2018
13
0
Brazil
Well, for the most part. Dealer found high carbon build up on the reed valves. they cleaned them up and I only had the bike stall 2 or 3 times over the winter.

I'm actually taking it in tomorrow for a belt change and just having them take off the evap canister. I'm thinking that also contributed to the issue.
I couldn't find a reason why the canister would make the bike stall. Would you guys be able to explain, or point to an explanation?
Mine is still in warranty, I might have to convince the dealer.
 
Mar 2013
2,334
4
Naples, IT
search it. Biggest problem is it vapor locking or something if you put too much gas in the tank. There's other issues my dealer went into just before it "fell off" during 1st service.
 
Jun 2019
34
0
Florida
search it. Biggest problem is it vapor locking or something if you put too much gas in the tank. There's other issues my dealer went into just before it "fell off" during 1st service.
Reading what? I'm having this problem now, died on deceleration coming to a stop light. Evan can removed long ago.
 
Last edited:
Mar 2013
2,334
4
Naples, IT
Reading what? I'm having this problem now, died twice on deceleration coming to a stop light. Evan can removed long ago.
Edgary has hyperlinks to threads in his post. You have to at least attempt a search before posting a problem thread. The Strada is 6 years old so not a lot of new problems we haven't discussed in depth.
 
Jun 2019
34
0
Florida
Sorry about that but I did use search to find this thread.. the only hyperlinks I see lead back to this same thread, am I missing something?
My canister has been off since I got the bike.. it looks like the hose to it is plugged and not leaking.