She done died...

Mar 2013
2,339
4
Naples, IT
Stradista's,

Bike died during a u-turn, won't crank. CEL and "ERRORS" come on with key and flash when I thumb the starter - nothing mechanical happens, however. Was on my to the gas station and it was bone dry when I checked it. Had the battery disconnected this weekend when I did some work and hoped that the ECU miffed the Trip Fuel calculation (I wasn't near my normal limit). No dice. Disconnected battery roadside and that didn't help. Battery was reading 12.7 volts.

Put a header on, checked the O2's, reset the RB map and some other minor things this weekend. Bike ran exactly as it did before until it died. I did have a standing CEL w/ "ERRORS". A couple weeks ago, the CEL started coming on as soon as I thumbed the starter, instead of around 130 F previously. This is why I thought I was having O2 issues and not something more serious...plus she ran strong.

Fortunately, I'm about 500 miles from 30,000 KM service. Nothing was cracked and it wasn't puking fluids. No funny smells. It died like it ran out of gas and I was on an incline. Is there a priming procedure I'm not aware of?

I only had to push her like 200 yards to safe parking so wasn't super pissed. My starter is only 6 months old and cranks very strong.

Start tossing those ideas!
 
Sep 2016
341
2
ABQ NM
This might sound stupid but I've had an issue with my bike dying when I part it and lock the steering head (really), something must be shorting because I need to replace my 30A fuses when it does, U-turn is like locking the head (if going left), my bike was stone dead, IF you can crank it, it's not this, I no longer lock my steering head when parked it hasn't done it since...
 
Mar 2013
2,339
4
Naples, IT
Wow, crazy. I never lock mine but was going to start after reading some bike theft articles. I mean, I did go full lock left on the turn...I'm checking fuses and basic shit this morning. I did fiddle with the side stand switch roadside. The blinking CEL/ ERRORS leads me to believe this is something worse.
 
Apr 2013
754
12
uk
check the fuses, check the wiring at the headstock, remove a plug to see if its wet and see if there is a spark, does the fuel pump prime.
 
Mar 2013
2,339
4
Naples, IT
Found a blown 10A in the frame fuse box; slot #4. The starter is working now but it won't turn over. The battery was showing around 12.4 V, so I put it on the charger. It felt strong at first so I fear this won't be the ultimate fix.

Can't say I've ever heard the pump priming. I don't have the flapper servo anymore so should be able to hear it. I haven't noticed it in the past. When it died, I didn't get any precursor misfires like when you normally run out of gas. It was running like a raped ape, did a u-turn, dead.

Next stop will be plugs and spark if it doesn't fire with the full battery.
 
Mar 2013
2,339
4
Naples, IT
If anyone has run out of gas, please share your experience. I never have so don't know if it needs a lot of kicks to prime or what.
 
Apr 2013
754
12
uk
Fuse four (front) fuse box feeds both the horizontal and vertical lambda sensors.
It gets its feed from the main relay, which is energised from the immobiliser.

If the fuse blows again, disconnect the lambda sensors.

I know a poor battery can cause all sorts of problems on modern motors, cars and bikes, not saying that's what it is on yours!
 
Last edited:
Mar 2013
2,339
4
Naples, IT
Very interesting. I've been suspecting lambda sensor issues for a while now - lots of backfires on decel, slightly ruff feeling, CEL was tripping at 130 F. About 2 weeks ago, it started popping when I thumbed the starter. I inspected both lambda's when I installed the header this weekend and the forward ECU-O2 plug had some corrosion on one of the pins. Cleaned it with sensor cleaner and a brush. No change. I swapped the RB to auto adaptive and checked the O2 cancel feature was active, too.

That would be super cool if it's just a low battery...
 
Jan 2015
340
1
Austria
If anyone has run out of gas, please share your experience. I never have so don't know if it needs a lot of kicks to prime or what.
ran out of gas 2 times with my 939 and after refill did not do anything than press starter and it awaked in 2 seconds to life
 
Similar Discussions Hyperstrada Forum Date
Ducati Hyperstrada
Ducati Hyperstrada